Haunted House Pinball Machine (Gottlieb, 1982)

Symptoms: Upper playfield pop bumper not working, lower playfield up kicker not working, playfield GI lights off, sticky flipper on lower playfield.
Location: Golden, CO

Sometimes when approaching a Gottlieb Systems 80 pinball machine, especially the Haunted House and Black Hole, which utilize different playfield levels, it’s easy to get overwhelmed. It’s good to stay focused on one problem at a time.

For the first issue, the pop bumper on the upper playfield had a broken wire.  Re-soldered the wire to the coil, and we checked that off the list.

The next issue was the playfield lights not working.  I found that the GI lighting fuse was blown. I replaced it, which solved the problem temporarily. I discovered later, while solving problems with the lower playfield, that the fuse blew again.  The “U” relay controls the power to the lights and the solenoids on the lower playfield.  When the machine senses the ball dropping down to the lower playfield, the “U” relay is activated.  It turned out, the lighting fuse would blow whenever the “U” relay activated.  That meant there was short in the lighting circuit on the lower playfield.

I’ve seen shorted lamp sockets on these machines in the past, where the center conductor pin shorts against the can of the socket. I checked each GI light socket and found one that was shorted on the left side. I bent the pins so they wouldn’t short, replaced the fuse and manually actuated the “U” relay, and the lights lit and the fuse didn’t blow again.

The problem with the lower playfield up-kicker was traced back to the big edge connector on the bottom of the Driver Board.  The ground for that circuit was not making a good connection.  I removed the old pin from the connector and replaced it with a new one.

When checking the operation of all of the controlled lamps, there was one lamp not coming on at all. I replaced the bulb, but that didn’t help.  I traced the problem back to the Driver Board. It appeared the transistor was blown.  I replaced the transistor and it still didn’t work.  It turned out that once again, this was a faulty connection at the card edge connector, except this time the pin was shorting across the row to another pin deep inside the connector, thus grounding out the circuit.  This is what caused the original transistor to blow. I replaced the pin and the lamp started working again.

After replacing a few bad bulbs, the machine was working and playing well.

Seeburg, LPC1 Jukebox

Symptoms: Scans back and forth without picking up record.
Location: Englewood, CO

There are a whole slew of reasons a Seeburg jukebox mechanism from the 1960’s and 1970’s will scan back and forth without picking up a record after pushing the selection buttons. It’s a common symptom without common fixes.

Seeburg was the only jukebox manufacturer from that era to use an electronic means to save selections that a customer selected. All other manufacturers used mechanical pins or levers. There are about a dozen items in a chain that have to work properly for the jukebox to make a selection, find the record and play it.

It’s best to start troubleshooting in the middle of the chain, which is the Tormat memory unit, then determine if the problem is a “write in” or “read out” problem. (Seeburg manuals refer to a third section called “trip”, but I include that as “read out”.)  Tony Miller, a former Seeburg engineer who has written books about working on Seeburg jukeboxes, has written a general guide for determining which part of the chain the problem is located. It simply uses a 1.5 volt battery to test which end of the chain is at fault.

In the LPC jukeboxes, there are two pulse amplifiers, one for each side of the record.  So there are in effect two “read out” and “trip” circuits.  Other models of Seeburgs use a single “read out” combined with the reversing switch to play both sides of the record.  I tested both “read out” circuits and they were fine.

There aren’t as many issues for the “write in” problems compared to “read out” problems. I found two problems with this jukebox, one more critical than the other.

The primary problem was the “write in” voltage was zero. This would normally be around 300 volts.  On TCC1 (Tormat Control Center 1) this can be measured at TS2 pin 2 (TS2 is a test connector facing the front of the jukebox on the TCC1).  Since I was getting zero volts there, I went directly to the OA2 voltage regulator tube (between the 27K and the 270K resistors) and I was getting the full 300 volts there.  So the problem was either the 270K resistor or downstream from it. I unplugged the Album Pricing Unit to isolate the TCC1.  The voltage was still zero. I checked the 270K resistor, and it was okay.  The only thing left was the 0.068uF capacitor.  It was probably leaking current to ground, causing a voltage drop across the 207K resistor.  I replaced it and the voltage came up to 290V which is good enough.

lpcwrite

Simplified schematic (corrected) from the manual showing a portion of the “write-in” circuit.

The secondary problem were the write trigger contacts in the Pricing Unit. I don’t have a photo handy, but they are mounted to a lever that rotates when the cancel solenoid is operated. The contacts are shown in the left yellow shaded area of the schematic above and on the diagram below.

Write trigger switch contacts.

Write trigger switch contacts.

One contact rests on an insulator and the other rests on a copper piece. When the cancel solenoid actuates, the disk rotates moving the copper under both contacts, making a connection. With age, dust and arcing (this switch creates a 300 volt pulse), these contacts often have carbon build-up on them.

I connected an ohm meter across the contacts and measured an “open” when I manually actuated the subtract solenoid armature.  I cleaned the contacts with some 2000 grit polishing paper, followed by some alcohol remove any grimy residue.   I rechecked and I got 0 ohms when I actuated the armature.

I put everything back together and made a selection and the mechanism stopped at the record and played it.  All fixed!