World Cup Soccer Pinball Machine, Williams, 1994

Location: Littleton, CO
Symptoms: GI lights not working, battery holder corrosion, tune-up

Only a few upper playfield general illumination (GI) lamps were working.  There was no voltage at the lamp sockets, so I looked in the backbox for the problem.

GI lighting connector burnt.

GI lighting connector burnt.

The GI lighting connector was burnt. This is a common problem with many pinball machines.  The root cause can be a number of things such as contact oxidation, a shorted lamp circuit, or even poor design forcing too much current through the connector pin.  Once the scenario starts, it is self destructive.  Any of these root causes will cause the connector to heat up, which in turn causes more oxidation on the metal surfaces, as well as reducing the spring tension on the female contact.  All of which cause it to get hotter until it fails.

Male header was also damaged.

Male header was also damaged.

pb-0125

Even the solder had melted on the end pin.

I replaced both the male and female connector with Molex Trifurcon which have a better current carrying capability than the originals.  The female pins contact the male pin on three sides instead of just one or two, giving it some redundancy.

This machine had been in storage for a number of years. The AA batteries that supply power to the RAM to hold the high scores, had leaked and damaged the battery contacts on the holder.  Fortunately, this era of WPC boards have the battery holder piggy-backed over the CPU board, so if the battery holders get damaged, the main CPU board doesn’t.

I removed the battery pack completely and also removed the RAM chip.  I replaced it with an anyPIN NVRAM module. The batteries are no longer needed.  Ever.

After tuning up and replacing a bunch of bulbs, the pinball machine was working great!

 

Star Wars Pinball Machine (Data East, 1992)

Location: Highlands Ranch, CO
Symptoms: Wrong wiring on switch and lamps, broken drop target

This is the first machine I’ve ever encountered that had an alarm system attached to the coin door.  I’m pretty sure the owner wasn’t even aware of it.

pb-0120

Coin Door Alarm System

The switch on the shift lever (used in place of the ball shooter) was disconnected.  The normally closed terminal of the switch had broken off.  Normally this terminal is used to hold the diode.  I re-wired the switch and diode and covered the diode and connections with shrink tubing.

There were a number of playfield lamps not working correctly.  Some were staying on, some weren’t working at all. I found that someone had disconnected the “Jabba’s Bounty” overhead light on the playfield and twisted the wires together.  This shorts out the lamp circuit.  Once I un-shorted the wires and reattached them to the lamp socket, many of the other lamps started working.  The remaining lamps were burned out.

The broken drop target was preventing the other drop targets from resetting.  The stem was jammed in the reset mechanism.

I ordered a new drop target, which comes blank.  There are Star Wars decal sets for sale on e-Bay, but they are missing the right target.  The sellers suggests just taking the left decal and turning it upside down.  I think it looks stupid.

Decal set with left decal turned up-side-down to make the right decal.

e-Bay decal set with left decal turned up-side-down to make the right decal.

Here is a link to the IPDB showing the drop targets.

Since I have the old broken drop target, I decided to scan and print a new decal.

Scanned and retouched decal image

Scanned and retouched right decal image

New drop target on left, original on right

New drop target on left with my decal, original on right

The colors don’t match exactly, but I think it’s better than an up-side-down decal.

If you would like the high resolution files for making your own right drop target decal, they can be downloaded here.  There are two .tif files contained in the .zip, one is the original scan without any touch-up, and the other is the touched-up version.

anyPin NVRAM module

When I was at the Pinball Showdown a few weeks ago, I picked up a couple of anyPin NVRAM modules from Rob at Pinball Classics (he had a booth there).

All pinball machines made prior to about 2000 use some type of battery system for maintaining the settings and high scores.  The batteries often leak and cause damage.

The “NV” in NVRAM stands for Non-Volatile, which means it will remember its contents with no power.  It uses a ferroelectric technology where the RAM contents are stored in tiny magnetic charges.

anyPin NVRAM module by Pinball Classics

anyPin NVRAM module by Pinball Classics

Since the Showdown, I’ve installed the modules in two of my customer’s machines.

The first machine was a Bally Bobby Orr Power Play in Windsor, Colorado. The CPU board in this machine had the original Ni-Cad rechargeable battery installed. It was leaking white alkaline from the ends. I de-soldered the battery from the board and installed the NVRAM module.  It worked right at startup; no other configuration was needed.

The second machine was The Games by Gottlieb located in Brighton, Colorado.  This uses the Gottlieb Systems 80A system.  Like the Bally, it has a rechargeable battery. The battery itself didn’t look too bad after 30 years of use.  But it would have started leaking soon.   The other problem is the customer doesn’t leave the machine on long enough to charge it up.  Powering up the pinball machine a couple of hours a week is not long enough to keep those batteries charged.

The old Gottlieb RAM chip was soldered on the CPU board, so I had to remove it, then installed the socket strips that come with the module.  (That machine also had a bad display driver chip that needed replacing.)  Everything worked flawlessly at power-up.

Williams and Stern pinball machines use AA batteries to remember their settings.  They leak if you forget about them.  I’ve got a customer with a Williams World Cup Soccer where the batteries leaked because the machine was in storage for a number of years.  The alkaline from the batteries ate through the tin plating on the battery holder and now there is a very unreliable connection to the batteries.

I can’t recommend these anyPin NVRAM modules enough!  Most of the machines I work on have some type of battery issue and this module is the long term solution.

Creature from the Black Lagoon Pinball Machine (Bally/Midway, 1992)

Location: Centennial (Denver), Colorado.
Symptoms: Blows fuse on power up.

When powering up the machine, the F114 fuse (8 amp) would blow.  This fuse powers the lamp matrix as well as the CPU +12 volt circuit through a downstream fuse (F115), which is used for the switch matrix.  So when I first power up the machine, the CPU was booting but none of the lights were flashing and the switches on the coin door were unresponsive.

I disconnected all of the lamp matrix connectors from the Power Driver Board (J133 through J138) and powered up the machine, and the fuse blew again. Since all of the connectors were disconnected and fuse F115 wasn’t blowing, the problem had to be in the power supply itself.  There are only two possibilities, a shorted bridge rectifier or a shorted capacitor (rare).  I check the bridge rectifier and it was shorted between “AC” and “+”.  I had a spare bridge rectifier on hand and replaced it.

The machine powered up as normal this time.  A lot of the matrix lamps weren’t working.  I replaced a bulb near the flippers and it still didn’t work.  I thought maybe a row or column driver had failed.  So I ran the test for individual lamps and marked a copy of the matrix with an “X” if the lamp wasn’t working.  No clear pattern emerged to indicate a row or column problem.

So I started at the first bulb in the test and looked at each one.  It turned out that most were burned out.  Also, I found a broken wire for Row 1 of the matrix.  Reconnecting that got about 6 more lights working, including the first bulb I had replaced where replacing it didn’t help.  It’s a tedious process, but in the end the machine looked and played well. I probably replaced two-dozen bulbs.

White Water Pinball Machine (Williams, 1993)

Location: Centennial, CO
Symptoms: Flipper problems.

The owner previously knew the lower right flipper coil was bad, so I had a replacement on hand when I arrived.  After replacing the coil, I checked all of the fuses on the Fliptronics board and found one blown and another fuse as the wrong value.  All four fuses should be 3 amp slo-blo (MDL type).

I powered up the machine and found that the flipper was often sticking in the up position.  Before the coil went bad, this was one of the original complaints.  It wasn’t a mechanical sticking, but the hold coil was staying energized when it should have released.  I tracked the problem down to the flipper opto board.  The bottom edge of the board wasn’t was tightened down all of the way.  The board was just twisting enough that it would move slightly when the flipper button was pressed, then it didn’t detect the button being released until some vibration in the machine caused the board to move a little.  I tightened the mounting screws and that problem was solved.

The upper right flipper was kicking but not holding.  It looked like all of the wires were connected to the coil and the terminals were wrapped in electrical tape.  So I looked at the Fliptronics board and checked the voltages coming back from the flippers.  When the game is powered up, in play mode, and flippers is NOT energized, 70 volts should be present on every terminal of J902 that has a wire connected to it (it varies from game to game based on the number of flippers).  This is a good way to check coils and connections.  In this case, there was no voltage present on pin 4. That verified that there was an open connection in the coil or the wiring.

So I went back to the coil for a closer look. I unwrapped the tape and found that the terminal strip on the end of the coil bobbin, where the connections are made, was broken.  It was the reason why it had been taped. The fine gauge wire used in the winding of the hold circuit had broken inside the coil.  Some coils can be repaired if the broken wire is on the outside layers of the coil, but in this case it wasn’t.

I generally don’t stock flipper coils, so I would have needed to order it. The owner elected to buy a new coil at the Pinball Showdown, which is happening this weekend in Denver.

Not all flipper coils are created equal for the Williams pinball machines.  Each pinball machine was designed to use specific coils based on what the coil needed to accomplish in each game layout.

  • FL-11753 Yellow – Used with short flippers and close shots
  • FL-11722 Green – Used for close shots near drop targets
  • FL-11630 Red – The standard, most commonly used coil
  • FL-15411 Orange – Used for long playfield shots
  • FL-11629 Blue – Used for long shots and high ramps

In the case of White Water, the blue coil is specified as the lower right and the red coil is specified for the upper right.

The Games Pinball Machine (Gottlieb, 1984)

Location: Brighton, CO
Symptoms: Pop bumper not working, display digit not working, needed cleaning and tuneup.

The machine was good condition.  I should have taken photos because the photos in the IPDB are of a machine in very poor condition.

The non-working pop bumper was simply a broken wire going to the coil. I resoldered it.  I checked the other pop bumper switches and noticed the top bumper’s switch was sticking.  If you press down on a bumper skirt and it doesn’t immediately pop back, you’re asking for a burned-out coil.  I cleaned the spoon that the bumper skirt rests on and that seemed to help a lot.  Often the pointed end of the bumper skirt that contacts the spoon gets roughed up and needs to be sanded or filed smooth and round again.  It’s a pain to do because it’s difficult to get to, and often involves removing it which requires taking the whole assembly apart.

The display on Player 3, least significant digit, was dead. I checked the card edge connector and made sure the card edge was clean.  I fired-up the oscilloscope and saw that the pulses (4 volt) were going into the digit driver IC, but no 60V pulses were coming out of the pin for that digit.  The other digit drivers within the IC were working fine.

The IC is a UDN6118A, which is no longer made.  These can the purchased used on E-bay from Chinese distributors. There was also a new one available at a US chip broker, for $15, plus $8.99 shipping.  Does it really cost $8.99 to ship something that weighs as much as a paper clip?  No!  For the same price, I can get 5-10 used chips from China.

For the time being, I swapped the Player 3 and Player 4 displays because the owner said the Player 4 gets used less often.  The owner is contemplating whether to repair the display or live with it.  I was surprised to see that PinScore doesn’t make aftermarket displays for Gottlieb (and neither does anyone else that I could find).

I also advised the owner that the rechargeable battery on the System 80A control board should be replaced before it leaks and ruins the circuit board.

I replaced bulbs and did a quick cleaning of the playfield.

When I played the game, I thought the sound board had something wrong with it.  There was a lot of background noise.  But it turns out the background noise is supposed to be crowd noise like at a stadium.  I verified by watching a YouTube video of the same machine.  You have to use your imagination.  I think it would have been better to have some background music with an Olympic theme.

 

Space Invaders Pinball Machine (Bally, 1980)

Location: Near Morrison, CO.
Symptoms: Blows fuse (F4).

The machine would immediate blow the fuse (less than 1 second) upon powering up.  Fuse F4 supplies the 43 volt solenoid circuits which are prone to broken wires, shorted coils, etc.  So, I expected to find a short somewhere on the playfield.   I isolated the power supply by removing all of the connectors except for J2 (cabinet) which supplies the wall AC power to the power supply, but this connector also supplies solenoid power to the knocker and the coin door.  The fuse still blew.  I checked the cabinet wiring to make sure there was no short, then focused on the power supply itself.

It turned out to be a shorted bridge rectifier between the AC and the minus (-).  I brought the power supply back to my shop for repair.  I looked up the part number for the bridge and found it on Marco’s site.  For better or worse, the bridge I received was slightly larger.  Not only were the pins further apart, it was also thicker.

New bridge rectifier (black square) above an original working bridge rectifier just below it.

This posed a problem as there are two bridge rectifiers in the circuit and both are mounted on the bottom side of the PCB and are heat-sinked against a metal bar on the power supply chassis.  If one is thicker than the other, one will be heat-sinked, the other will not.

I decided to shift the bar over, so that existing bridge would contact the bar and the new bridge would go directly to the chassis.

With the metal bar, both rectifiers will contact the chassis when the board is remounted.

I added some new heatsink grease to both bridges.  I powered the circuit and all was fine.  This power supply was only used on two machines, KISS and Space Invaders.

Back at the customer’s location, the game powered up and worked fine.  I replaced a few burned out bulbs.  The NiCad RAM backup battery mounted on the CPU board has partially failed. I am debating whether to replace it with a 1 farad super cap, or the typical 3 cell AA holder.  The super cap requires the machine to be powered up periodically so that it can recharge.  The AA batteries don’t require recharging, but there is no nice place to put the battery pack and they have to replaced every few years.

 

Funhouse Pinball Machine, Williams (1990)

Location:  Greeley, Colorado.
Symptoms:  Many.  Bulbs out, trap door not working, a pop bumper not working, both sling-shots not working, flipper sticking, etc.  Needed general servicing.

The biggest mystery with this machine was that every GI (General Illumination) bulb was burned out, except for 3.  I suspect that at some point in the past, there was a GI short to a solenoid supply which blew most of the bulbs.

As I was replacing some of the controlled lamps, I discovered some that were burning very brightly.  This raised a red flag that one of the rows or columns in the lamp matrix was stuck on.  The easy way to check this is to go into the test menu and run the single lamp test.  If more than one light comes on at a time, then the row or column driver is shorted or bad.   It turned out to be Column 8 and the TIP107 transistor.  All of the Column 8 lamps would light when any of the other columns were on.  After replacing the transistor, the controlled lamps all worked except one.

The one lamp that didn’t work was the “Open Trapdoor W/Flashing” light.  It was lighting when any other column or row was lit. In other words, the only time it acted normal was when any thing in its own column or row was lit. At first I thought it was a shorted diode.  The diode tested OK with the meter.  But the meter doesn’t test the diode at greater than 3 volts.  So I snipped it and the light should have gone dark, but it didn’t.  It turns out, someone had soldered the wires onto the socket incorrectly and bypassed the diode.  Once I corrected the wiring, it worked fine.

As for the sticking flipper, it was a bad link that was catching on the end of the solenoid.  I replaced the links, plungers and rubbers on both lower flippers.  The upper flipper looked good enough to leave alone.

The other solenoid problems were all related to broken wires.

The trap door wasn’t working because the end of the spring broke on the solenoid that latches it up.  I found the spring in the bottom of the machine and made a new hook with my pliers, and reattached it.

The game had an L4 version Game ROM (U6) installed.  The most recent official version is L9, plus there is an L9.05H, which is a home version with some additional features.  The difference between and L4 and L9H requires a move to a larger ROM (1 Mb to 2 Mb), plus one of the sound ROMs (U18) had to get upgraded to L3.

The L9H ROM images I downloaded from ipdb.org didn’t really match the documentation.  The U6 ROM image was a 4 Mb image, and U18 was a 2 Mb image.  In this Funhouse machine, both of these parts were 1 Mb so I couldn’t erase and re-program.  I was out of 2 Mb EPROMs.  So I ordered some blank 2 Mb parts from Marco and received 4 Mb parts instead. Ugh!  I looked at the schematic for the sound board and saw that it would support a 4 Mb ROM.  So, I programmed both images into 4 Mb EPROMs.  This works fine for U6, but for U18 it doesn’t work without loading the code into the upper half of the EPROM to make it look like a 2 Mb part.  Although the sound board hardware supports the 4 Mb ROMs, the firmware in the other sound ROMs doesn’t.

A note on CPU jumpers for larger ROMs:  I think by default, the early WPC games had the W2 jumper installed.  W2 supports the 28 pin ROM families and will still work with a 1 Mb 32-pin ROM because the associated pin on the 1 Mb ROM is not used.  But anything larger (2 Mb or greater) will need the W2 jumper removed and the W1 jumper installed.  The W1 jumper supports all of the 32-pin ROM families.  So when using a 1 Mb ROM, the jumper can be in either position.

The same is true for the sound board with regards to U18.  Jumper W4 supports the 28-pin families and jumper W3 supports the 32-pin families, with the 1 Mb ROMs not caring which position the jumper is in.  But keep in mind that at least for Funhouse, the sound system firmware doesn’t support anything larger than a 2 Mb ROM in U18.

After correcting dozens of small problems, the pinball machine is looking and working great!

Haunted House (Gottlieb pinball machine, 1982)

Location: Wellington, Colorado.
Symptoms: Would blow fuse as soon as ball landed on lower playfield.

The problem was obviously a short related to something that powered the lower playfield.  I inspected the wiring and coils on the lower playfield and didn’t see any issues.  With the machine off, I checked for shorts in coil and flipper power wiring and didn’t see any.  I finally found the short with my meter in the playfield illumination wiring, and it turned out to be on the main playfield.

On the underside of the main playfield, there are 8 lamps that light the lower playfield. These lights only illuminate when the ball is on the lower playfield, and are controlled by a relay.  Next I did a visual inspection of each of the 8 lamps, and as usual, found the short on the last one I checked. 😉  The center contact was shorted against the side of the socket, which is typically where lamp circuits short out.

The owner had replaced all of the lamps with LEDs.  One important thing to note:  On Haunted House and Black Hole, these 8 illumination lamps are powered by 28 volts, which will blow out regular 6 volt LEDs.  The original bulb number is a #313. You either have to use an LED specified to replace a #313 bulb, or you have to modify the lighting circuit to operate on 6 volts (a procedure is here).

 

Star Trek: The Next Generation (Williams pinball machine, 1993)

Location: Littleton, Colorado.
Symptom: Left cannon/gun shooter wouldn’t find its home position.

This one had me stumped for a while.  If I executed the diagnostic test for the gun shooter, it found the home position normally, without fail.  Yet when powering up/booting the game, it just cycled back and forth.   I checked and adjusted everything associated with the home microswitch.  I finally concluded there had to be a bug in the firmware.

It turns out I was partially correct.  There is an optical sensor located at the front of the gun to sense when the ball is in position and ready to be fired.  If this sensor fails, the revision LX-3 firmware ignores the home switch, will not home the gun, and it gives an incorrect error message. This post helped steer me in the right direction.

I burned (programmed) a new game ROM with more recent LX-7 code.  In the revision history, there is mention of “Enhanced the broken gun launcher opto compensation.” I don’t know if it fixes the problem of the incorrect error message or not, because I went ahead and fixed the opto sensor problem.

To troubleshoot the opto sensor problem, I first checked the voltage across the IR transmitter located on the left side of the cannon. It was about 1.3 volts, and this normal. Next I checked the voltage across the phototransistor located on the right side of the cannon.  It was reading zero volts, with or without blocking the light beam.  A properly working sensors would have approximately 12 volts across it with the light beam blocked, and between 0 and 1 volt with the beam unblocked.

Next, I checked the continuity through the wires down to the first connector under the playfield.  It turned about both wires were bad.  I noticed that the shooter solenoid wires to the gun had previously been replaced as well. It is a common problem that flexing wires thousands of times will break them.  I suspect they are broken where they go through the playfield.

I ran two new wires from the phototransistor down to the connector and left the old wires in place. That fixed all of the problems.

ST:TNG is one of my favorite pinball machines in terms of theme execution.  The audio clips are great and integrate well into game play.