Rockola 1488 Jukebox (1960)

Location: Henderson, Colorado
Symptom: Turntable speed too slow

One of the most common problems of Rockola jukeboxes from the mid-1950’s through the 1980’s, is the turntable not turning at the correct speed. This is almost always associated with the old rubber grommets that hold the turntable motor.

Height comparison of new turntable motor grommet with old grommet.

Height comparison of new turntable motor grommet with old grommet.

The turntable motor basically hangs from three of these grommets.  As the grommets age, they get dry and brittle and shrink and the motor gradually sinks.  I assume the weight of the motor is not evenly distributed among the three grommets because it seems like 2 out of the 3 are in worse shape. This causes the motor to tilt and the shaft is no longer aligned properly.

This photo only shows two of the grommets, but you can see that rear grommet is more compressed.  The motor has already been removed.

This photo only shows two of the grommets, but you can see that rear grommet is more compressed. The motor has already been removed.

What’s worse is that many of these jukeboxes are designed to play 33 RPM records. The motor shaft has two milled diameters, the bottom one is for 45 RPM and the top one is for 33 RPM records. As the motor sinks, the idler wheel begins to ride on the 33 RPM portion of the shaft.

Generally these grommets are easy to replace. The motor will be mounted in a variety of ways depending on the jukebox, most using screws or shafts with spring “E” clips. One source for new grommets is here.

High Speed, Pinball Machine (Williams, 1986)

Symptoms: Some game-play functions not working, display issues, flasher bulbs not working.
Location: Frisco, Colorado.

When entering the test menu, the machine displayed a number of switch error codes. These switch error codes were causing the game to play incorrectly, for example, not diverting the ball to the “hide-outs”.  Although the error codes indicated 4 switches, only one was not working.  Ramp switch #42 wasn’t working, which prevented the ramp ball diverter from actuating, which caused the machine to think the other switches were also bad because the ball never rolled over them.  I cleaned switch #42 (very stubborn) and got it working.

Some segments of the alpha-numeric displays were not lighting up.  I traced this to cracked pins on the display tubes themselves.  I was able to repair some pins by soldering, but there was one pin broken right at the glass and couldn’t be soldered.  The owner deferred further repairs to the display. The options would be to replace the glass display tube or convert the game to new LED displays, such as PinScore.

When testing the bulbs, I noticed that none of the flasher bulbs were working. In this particular version of High Speed, the flashers are connected in series with a non-standard 7 volt bulb, #63.  Most pinball machines use 13 volt #89 bulbs for flashers.

The problem with bulbs connected in series is that when one bulb burns out, the other bulbs in the string stop working as well. This makes it difficult to determine which bulb is actually bad.  In High Speed, the bulbs are connected in pairs.  To make matters more unintuitive, the pairs are interleaved.  So for example, the 4 bulbs for the left center playfield are paired 1, 3, and 2, 4.

I had to take each bulb and test it with an ohm meter to determine the bad bulbs.  Once I got good bulbs paired with good bulbs, the flashers started working.  Since the whole theme of the game is associated with being chased by the police with flashing lights, I can’t imagine it was much fun to play without the flashers.

 

Super Nova Pinball Machine (GamePlan, 1980)

Symptoms: Display issues, switch matrix problems, roulette wheel problem, sound problems, lamp problems.
Location: Lyons Classic Pinball, Lyons, Colorado

I’ve been working on a couple of GamePlan pinball machines recently (Andromeda is the other one).  There is nothing particularly difficult about working on GamePlan machines with the exception of getting replacement mechanical parts.

This Super Nova pinball machine has an aftermarket market MPU board installed.  The aftermarket board uses an integrated RAM/Lithium battery component.  This is really a bad idea.  What happens when the battery dies?  It’s not replaceable without also replacing the RAM it’s attached to.  If there is anything I’ve learned in 30 years of electronics, that RAM/battery component will no longer be available when the battery needs to be replaced. This will render the board useless at some point in the future.

There was a display problem with most of the LED digits with segments that weren’t working.  This was related to the edge connector that connects to the MPU board.  Someone had added solder to the edge connector, presumably to get it to fit tighter, but it was uneven.  I took some 400 grit emery paper and sanded down the contacts so each had just a thin layer of solder.  This corrected the display issues.

This machine had several problems with the switch matrix.  You can download a .pdf of the Super Nova switch matrix here. The matrix consists of 40 switches arranged by 5 “strobes” (outputs) and 8 “lines” (inputs).

The first problem was with the Switch Catcher Unit (SCU-1) circuit board mounted on the underside of the playfield.  There are 4 switches connected to this board.  (The purpose of this board is to make sure the MPU doesn’t miss a quick hit to these switches; it lengthens the switch pulses.) When any of the switches made contact, it would momentarily short the 5 volt supply causing the machine to crash/reset. I traced this to a faulty 74279 chip.

pb-8980

Switch Catcher Unit (with faulty 74279 removed and a new socket installed)

Some of the solder joints on the backside of the connector were cracked and needed to be resoldered.

The second problem with the switch matrix was that every switch connected to Strobe #1 wasn’t working.  I traced this to a faulty connector at the MPU board.  It was just one pin that was bad.   None of the connectors used in this machine are standard Molex.  So rather than replacing only the bad crimp pin, I ended up replacing the entire connector.

Now that the displays and switches were working, I tested all of the solenoids.  The only thing that wasn’t working was the spinning roulette wheel (the Space Lab).  I traced this to a bad relay and a bad transistor driving the relay. The relay had been previously replaced with the wrong one. There was a 6V relay instead of a 28V relay. At some point the transistor that drives it shorted and burned up the coil.  After replacing both, the Space Lab wheel worked fine.

Next on the list was fixing the sound.  It was only making a single sound when playing the machine.  Usually when a machine has sound problems like this, I will check to see if there are any videos on YouTube so I can see how the sound is supposed to behave. The first thing I noticed is that there is no background sound during play.

There is a jumper on the sound board that enables or disables background sound. This was missing.  If background sound is desired, the jumper should be in the left position as shown in the photo below.

Sound Board with jumper for background sound circled.

Sound Board with jumper for background sound circled.  (Click for larger)

After installing the jumper, I was still missing many sounds. Using the oscilloscope, I check for pulses on the sound select inputs and there were none.  The problem was with the connectors at the bottom of the backbox.

Connectors at bottom of backbox.

Connectors at bottom of backbox.

At some point in the past, presumably with the original MPU board, the battery leaked and caused most of the connector pins to corrode.

Corroded connector pins.

Corroded connector pins.  The tip of the  male pin on the right had broken off.

All of the remaining problems with this machine were related to these backbox connectors. I don’t know the manufacturer of the original connectors, but I was able to find some Molex pins that worked (Male: 02-08-2004, Female: 02-08-1002). The old pins were removed from the housings using an extraction tool. Then the holes in the housings for the Molex male pins had to be enlarged using a 7/64″ drill.

Indiana Jones: The Pinball Adventure (Williams, 1993)

Symptom: When starting game, 6 balls would eject into shooter lane.
Location: Denver, Colorado

Obviously, there was a problem with the ball trough optical sensors.  Upon closer examination, there was no +12V supply voltage on either the IR emitter side of the trough or the receiver side.

To the backbox we go.  The +12V for misc playfield sensors comes off the lower left of the Power Driver board. There are several 4 pin connectors located there (J116, J117, and J118).  All of the connectors looked good.  I checked the +12V there and it was still missing.

Fuse F116 was blown, which supplies the 12 VAC to the rectifier, which generates the DC version of the voltage.

 

Circus Pinball Machine (Gottlieb, 1980)

Location: Loveland, Colorado.
Symptoms: Displays not working, playfield lighting blows fuse.

I was really impressed by how immaculate this machine was.  It looked like it had just been un-crated.  It definitely had low miles on it.  No doubt home-use only.

The interesting thing about the displays is that the credit/ball-in-play display was working, and the score displays were not working.  They were dark/off.  I spent a few minutes looking at the schematic, searching for what was in common with the score displays, and at the same time, not in common with the credit/ball-in-play display.  There was only one thing: the filament voltages for the display tubes.

The score displays run off a 5 VAC filament supply and the credit display uses a 3 VAC filament supply. So I started by measuring the filament voltage at the Player 1 display and sure enough, zero volts.  I lifted up the playfield and found the 5 VAC leaving the power transformer.  So somewhere in between a connection wasn’t being made.

I found the problem at a wire to wire backbox connector. In this case, there was a pin that wasn’t crimped correctly at the factory.

Crimp pin was installed incorrectly at the factory.  The wire was inserted too far and the crimp went around the insulation rather than the conductor.

Crimp pin was installed incorrectly at the factory. The wire was inserted too far and the crimp went around the insulation rather than the conductor.

If I held the wire a certain way, the displays lit up.  I replaced the pin with a new one and all was good.

The next issue was that the general illumination lighting on the playfield would randomly blow a fuse.  This is usually caused by a short at one of the sockets.  I checked each socket and found one that had been damaged (right near where the prop bar is used to prop up the playfield). Just the slightest vibration would cause it to short out.  I replaced that socket and one other socket that was marginal.

 

West Slope Lubrication Tour

Locations: Basalt, Colorado; Grand Junction, Colorado.

First stop was to work on a Wurlitzer jukebox model 1100 (1948). Like many 1940’s Wurlitzers I’ve worked on, the selector shaft and heart-shaped cam was not rotating due to lack of recent lubrication. This causes it to play one selection regardless of what was selected.  Unfortunately, it’s not an easy thing to get freed up, and takes a lot of exercising and time.

The jukebox needed some other adjustments, such as the turntable height and the clutch. I replaced the line cord because it was in very dangerous condition. The color cylinder plastic sheets were also replaced.  This was an original, un-restored 1100 in good condition.

Next stop was to work on two Williams electro-mechanical (EM) pinball machines, Grand Prix and Aztec (both 1976).  The main problem with these machines were the stepper units were not freely ratcheting up and down. This is the number one problem with EM pinball machines.  A quick disassembly, cleaning and lubrication fixes the problem.  Occasionally the spring tension needs to be adjusted.

The Aztec was missing some electrical parts, which can’t be obtained unless someone is parting one out.  But I got it working as best I could.

Next stop was an AMI jukebox, model A (1946), which is also known as the Mother of Plastic. The selection mechanism was frozen due to lack of recent lubrication.  Like the 1100 above, it took a while to get it unfrozen and moving freely.  The selection buttons needed some contact cleaning and lube (buttons would stick when pressed). The tonearm wire where it plugs into the amp needed to the resoldered.  All in all, a great sounding jukebox.

It was satisfying to breathe some new life into these old machines.

Alien Poker Pinball Machine (Williams, 1980)

Location: Boulder, CO
Symptoms: Incorrect sounds

The sounds on this pinball machine were working when the machine was first turned on.  But after a very short time, the sound would go wonky.

After some discussion with the owner, we determined that the sounds themselves were not defective, it was just the wrong sounds playing at the wrong time.  For example when hitting a particular target you’d hear the ball drain sound rather than a speech clip.

Pressing the self-test on the sound board yielded all of the correct sounds.  This indicated that the sound select signals from the MPU board were not correct.  With the oscilloscope, I looked for pulses on pins 10-14 on IC 10 on the sound board, while the owner triggered things on the playfield.  Some signals were missing.  When I checked the same signal at J3, they were present.

The culprit was cracked solder joints on the connector.  In the photo below you can see cracked solder around the top three and the bottom three pins on the connector.

Cracked solder joints on connector pins.

Cracked solder joints on connector pins.

At the owners request, I pulled all of the boards out of the backbox and touched up any solder joints that looked suspicious.  After that, the proper sounds sounds played at the proper times.

 

Seeburg Jukebox SHFA1 amplifiers

Location: Littleton, CO
Symptoms: Two amplifiers, both barely working.

Of all of the amplifiers I’ve rebuilt, I’ve never encountered an amplifier with so many bad capacitors as I have on these amplifiers.  Compared to Wurlitzer, Seeburg must have been trying to use the cheapest capacitors they could get their hands on.  I suppose a lot of it has to do with how many hours the jukebox was on and the temperature inside the amp chassis.

I replaced all of the electrolytic capacitors on both amplifiers.  As I pulled each one out, I was hard pressed to find one that was within 20% tolerance of its original value.  And many were not even close, such as a 50 uF reading 0.6 uF.

In addition to the electrolytic capacitors, many of the paper/foil capacitors have been bad as well. These capacitors play a variety of roles, mainly used to block high voltage and couple the audio from each vacuum tube stage to the next. Failures with these capacitors, usually high current leakage, will usually cause a tube to be biased incorrectly. This is especially important in the final power amplifier stage and in the “cathode follower” stage just prior to the volume control.

Also, with the SFHA1 in particular, the Automatic Volume Compensation (AVC) circuit will cease to work.  And when this happens, most people pull the 6BJ6 tubes to disable the AVC circuit, which explains why many amps of this vintage are missing these tubes.

One might be tempted to replace every capacitor, but given there are nearly 80 capacitors in this amp, I prefer to replace all of the electrolytics (21 capacitors), since they have a finite life, and then replace the others (which, in theory, should have a longer life) as needed.

Below I list some of the problem non-electrolytic capacitors. If you read on, you should have a schematic to refer to.

Preamplifier, prior to the volume control

On both of these amplifiers, C108 and C147 (0.22 uF, 400V) were leaky, causing attenuation of the audio signal, even when the AVC tubes (6BJ6) are removed.  This is usually the reason one channel might be louder than the other. These are very large and mounted to the rear side of the larger circuit boards near the sides of the amplifier chassis.

On both of these amplifiers, C121 and C160 (0.005 uF, 400V) were leaky, causing the voltage on V103, V109, pins 7 and 8 to be too low.  This causes clipping and thus distortion of the audio waveform.  The voltage on the schematic for pin 8 (cathode) is listed as 90V.  Before the bad capacitors were replaced, it was reading around 14V.  This circuit is the “cathode follower” I mentioned above.  These capacitors were among the first to be installed and are buried deep under everything else. These capacitors connect between Pin 7 of the tube and the wiper of the treble control.

One amplifier had some distortion in the waveform in one channel that was caused by C110, C150 (0.005 uF, 400V).

Automatic Volume Control

When there is no signal coming into the amplifier, the voltage across C115 (1 uF) should be zero or within a 1 or 2 volts of zero. If it isn’t, then C111, C148  (0.01uF 400V) should be replaced.  One channel on each amplifier had a leaky capacitor.

Likewise, when you have a 4 – 8 mV signal on the amplifier inputs, and pin 3 of muting socket is grounded,  the voltage across C115 should be 30 to 50 volts.  If it isn’t, and everything else is working, then C115 itself is the problem and should be replaced.  One amplifier had this problem and the voltage would never go above about 6 volts, in spite of being nearly 50 volts of signal at the cathode of the selenium rectifiers.

Final Power Amplifier Stage

The 6973 tubes are used in pairs for each channel. They operate in a push-pull configuration.  If the bias of the grid is not correct or if one tube is weaker than the other, the circuit doesn’t work very well.  It’s like a teeter-totter, where the people on it should be nearly the same weight to have a good balance.

On the 6973 tubes (V105, V106, V111, V112) you should see -33 to -35 volts on pins 3 or 6 of each tube (with no input signal on the amp).  A leaky capacitor will cause the voltage to be more positive. The capacitors associated with each tube in the order listed above are C137, C138, C175 and C176 (0.05 uF, 600V).  On one amplifier, all 4 capacitors were bad.  On the other amp, all were good.

Tubes

Usually I don’t see many bad tubes in jukebox amplifiers. Almost all problems are related to bad capacitors. But…

I had a bad 5U4 that was shorting and blowing the fuse.  I had one pair of 6973 that was bad on each amplifier (these should be replaced in pairs).  I had a bad 12AX7 on one amplifier.  And one amplifier had missing 6BJ6 tubes.  With the exception of the 6BJ6 tubes, there are companies still making vacuum these tubes.  Try finding a company still making vintage transistors.

I highly recommend Vacuum Tube Supplies in Denver for anything related to tubes and tube amplifiers.

Quick Draw Pinball Machine, Gottlieb 1975

Location: Fort Collins, Colorado.
Symptoms: Score reels sticking, not resetting, 50 and 500 points items not scoring, not always advancing to next player or ball, bonus countdown issues, score accumulating when switching players.

The machine has been missing the rear door for the backbox for a long time and a lot of dust had settled in there.  The switch contacts on the player unit needed cleaning and adjusting.  This accomplished a lot in eliminating problems. The score advancing when changing players was due to the reset contacts (switch stacks P3 and P4) vibrating or set too close.

The player unit keeps track of ball numbers, player turns, and controls the reset of the scores. What makes working on the player units difficult is that the switch stacks are very close together. I’ve made a home-made switch adjusting tool that is able to fit in between switch stacks. I’ve also made some cleaning strips with a jogged shape them to help with switch cleaning.

Some of the decagon units needed to be rebuilt and contacts cleaned. A majority of the time was spent in the backbox.  The owner will craft a new back door to help keep the dust out.

There were a few other mis-adjusted contacts on the bonus unit and the 50 and 500 point relays.

Another EM pinball machine saved.

Close Encounters of the Third Kind Pinball Machine (EM version), Gottlieb (1978)

Location: Parker, Colorado.
Symptoms: Machine not resetting, points not registering, drop targets not resetting, bad light socket, and various other problems.

This is the rarer electro-mechanical version of this pinball machine.

On most EM machines, you can disconnect the credit subtract coil to put the game in Free Play mode.  However, on this machine, there are switch contacts on the credit subtract lever that trigger the Start Relay (S). I bypassed those with a wire.

Next, the relay coil spring on the Reset Relay (AX) had been previously replaced with the wrong one that was much weaker.  I traded the spring from the Hold Relay, where the spring tension is less critical, to the Reset Relay and then re-adjusted the contacts. This fixed the problem with the machine not resetting correctly.

Next, many of the point scoring relays such as the 500 point and 5000 point were not holding though a cycle of the score motor.  They are all common and routed through the normally closed Motor 2B switch.  This switch was simply out of adjustment.

Eight relays are routed through a common hold switch on the score motor.

Eight relays are routed through a common hold switch on the score motor.

One of the formed switch blades had broken off the score motor and a replacement was obtained from The Pinball Resource.

Broken formed switch blade from Score motor.

Broken formed switch blade from Score motor.

Some of the contacts on the player unit needed to be cleaned and adjusted, which is a typical problem with Gottlieb multi-player machines. The bonus stepper unit was gummed up and not advancing or awarding bonus.  It was cleaned and rebuilt.

The spinner switch needed adjusting because it was scoring points with just vibration from the playfield.

After replacing a broken light socket and spraying the back side of the backglass with Krylon Triple Thick Clear Glaze (to help stabilize the paint and keep it from peeling), the machine was looking and working great!