Seeburg AY/AQ 100/160 Jukeboxes

Symptom:  After about 15-20 minutes, the mechanism no longer stops at selected records.

I’ve come across a couple of Seeburg jukeboxes of this vintage that have had this problem.  It has been a difficult problem to diagnose in the field, but I was fortunate that an owner allowed me to take the Tormat Selector Unit (TSU) back to my home office where I could bench-test it and really dig down to find out what the problem is.

The first thing I had to do was replace R513 (2.2 Meg) because the -7 volt test signal wasn’t working.  This test voltage is present on TP-C.  Momentarily feeding this voltage into the RCA jack where the Tormat plugs in (J510) will test the pulse amplifier.  The Tormat Pulse Amplifier (TPA) is the gold colored box mounted to the TSU, with a 12AX7 tube on it.

Tormat Pulse Amplifier (TPA)

Tormat Pulse Amplifier (TPA)

Fairly quickly, I was able to determine the problem was in the pulse amplifier.  I hooked my oscilloscope to the output at Pin 4 of the TPA socket (J509), accessible from the rear of the TSU.

I connected a jumper lead from TP-C to the shaft of a small Phillips screwdriver that would fit into the RCA jack.  Moving the screw driver in and out would send pulses through the amp.

Output of pulse amplifier when working correctly.  Pulse is about 75 milliseconds.

Output of pulse amplifier when working correctly. Pulse is about 75 milliseconds.  Note ground is at top of pulse and the output normally sits at about -76V.

When everything was cool, the pulse output was 75 milliseconds long.  As the TPA and TSU warmed up, the pulse got shorter and shorter until it was gone.

Output of pulse amplifier after it warmed up.

Output of pulse amplifier after it warmed up.  Pulse is now way too short to trip the mechanism solenoid.

After trying a new 12AX7 tube, I opened the TPA box and checked the resistors.  Some were marginally out of tolerance (all to the high side), but this was minor.  Using hot air, I heated the amp and measured the resistors again and there wasn’t a significant change.

I measured the capacitance of C506 (0.05uF, 400V), which is partially responsible for stretching the pulse to 75 milliseconds.  It was 40% higher than it’s rated value.  As I heated it up, it’s value more than doubled from it’s already high value.  This was the culprit.

The closest capacitor I had on-hand was 0.05uF at half the rated voltage.  Since I wasn’t seeing more than 195V in the circuit, I tried a 200 volt cap as a temporary fix.  And it worked!  The pulse output remained at 75 milliseconds throughout the hour I tested it.  I have ordered the 400V version of the cap as a permanent replacement.

New capacitor installed.

New capacitor installed.

I’m glad to have finally solved this mystery.

 

 

2 thoughts on “Seeburg AY/AQ 100/160 Jukeboxes

  1. I have a similar problem with a DS100. I have had Joe Bloodgood, Harvey Lee and Dick Hack all look at it and no one has come up with a solution, although Joe has offered to buy the jukebox “for parts”. I am ready to attempt replacing the stepper capacitor myself as on inspection my unit has been replaced with a 0.047uF, 400 v. cap. The 0.05uF, 400 v. caps don’t seem to be readily available, or I’m just looking in the wrong place. Please advise.

    • My guess is the capacitor has already been replaced. The 0.047uF is the more modern equivalent of a 0.05uF, the difference in capacitance values is negligible and is not critical in that circuit. The capacitor is not the only thing that could cause this problem. It’s just I’ve seen enough of original ones go bad that it’s worth checking fairly early in the debugging process.

      In my opinion, it’s a conflict of interest for a repair person to offer to buy a non-working jukebox or pinball machine.

Leave a Reply to Matt Rinehart Cancel reply

Your email address will not be published. Required fields are marked *